BGP Basic Configuration
v
R2 interfaces Configuration:-
Ø
interface
FastEthernet0/0
Ø
description CONNECTED
WITH SW1
Ø
ip address 192.192.12.2 255.255.255.0
Ø
no shut
Ø
exit
v
R1 interfaces Configuration:-
Ø
interface FastEthernet0/0
Ø
description CONNECTED
WITH SW1
Ø
ip address 192.192.12.1 255.255.255.0
Ø
no shut
Ø
exit
Ø
interface
Serial0/0
Ø
description CONNECTED
WITH R1
Ø
ip address 192.192.1.2 255.255.255.252
Ø
clock rate 2000000
Ø
no shut
Ø
exit
Ø
interface
Serial0/1
Ø
description CONNECTED
WITH RELIANCE_ISP
Ø
ip address 192.192.1.6 255.255.255.252
Ø
clock rate 2000000
Ø
no shut
Ø
exit
v
Airtel_ISP Interfaces Configuration:-
Ø
interface
Serial0/0
Ø
description CONNECTED
WITH R1
Ø
ip address 192.192.1.1 255.255.255.252
Ø
clock rate 64000
Ø
no shut
Ø
exit
Ø
interface
Serial0/1
Ø
description CONNECTED
WITH VODAFONE_ISP
Ø
ip address 200.200.1.5 255.255.255.252
Ø
clock rate 2000000
Ø
no shut
Ø
exit
v
Reliance_ISP interface Configuration:-
Ø
interface Serial0/0
Ø
description CONNECTED
WITH VODAFONE_ISP
Ø
ip address 200.200.1.1 255.255.255.252
Ø
clock rate 2000000
Ø
no shut
Ø
exit
Ø
interface
Serial0/1
Ø
description CONNECTED
WITH R1
Ø
ip address 192.192.1.5 255.255.255.252
Ø
clock rate 2000000
Ø
no shut
Ø
exit
v
Vodafone_ISP interfaces Configuration:-
Ø
interface
Serial0/0
Ø
description CONNECTED
WITH RELIANCE_ISP
Ø
ip address 200.200.1.2 255.255.255.252
Ø
clock rate 2000000
Ø
no shut
Ø
exit
Ø
interface
Serial0/1
Ø
description CONNECTED
WITH AIRTEL_ISP
Ø
ip address 200.200.1.6 255.255.255.252
Ø
clock rate 2000000
Ø
no shut
Ø
exit
Terms:-
Ø
{Remote-as:-Specify a BGP neighbor Autonomous No. {AS No}
Ø
BGP Synchronization:- Do not use or advertise a route learned via
IBGP until the same route has been learned from the internal routing protocol
Ø
BGP next-hop-processing:-
ü
For EBGP peers:- change next hop address on advertised routes
ü
For IBGP peers:-do not change next hop address on advertise routes
v
R2 BGP Configuration:-
Ø
R1(config)#
router bgp 65001
Ø
no synchronization
Ø
bgp router-id 2.2.2.2
Ø
network 192.192.12.0 mask 255.255.255.0
Ø
neighbor 192.192.12.1 remote-as 65001
Ø
neighbor 192.192.12.1 description
R1
Ø
no auto-summary
v
R1 BGP Configuration:-
Ø
R2(config)#router
bgp 65001
Ø
no synchronization
Ø
bgp router-id 1.1.1.1
Ø
network 192.192.1.0 mask 255.255.255.252
Ø
network 192.192.1.4 mask 255.255.255.252
Ø
neighbor 192.192.1.1 remote-as 65002
Ø
neighbor 192.192.1.1 description
AIRTEL_ISP
Ø
neighbor 192.192.1.5 remote-as 65004
Ø
neighbor 192.192.1.5 description
RELIANCE_ISP
Ø
neighbor 192.192.12.2 remote-as 65001
Ø
neighbor 192.192.12.2 description
R2
Ø
no auto-summary
v
Airtel_ISP BGP Configuration:-
Ø
Airtel_ISP(config)#router
bgp 65002
Ø
no
synchronization
Ø
bgp router-id 3.3.3.3
Ø
network 192.192.1.0 mask 255.255.255.252
Ø
network 200.200.1.4 mask 255.255.255.252
Ø
neighbor 192.192.1.2 remote-as 65001
Ø
neighbor 192.192.1.2 description
R1
Ø
neighbor 200.200.1.6 remote-as 65003
Ø
neighbor 200.200.1.6 description
VODAFONE_ISP
Ø
no auto-summary
v
Reliance_ISP Configuration:-
Ø
Reliance_ISP
(config)#router bgp 65004
Ø
no
synchronization
Ø
bgp router-id 4.4.4.4
Ø
network 192.192.1.4 mask 255.255.255.252
Ø
network 200.200.1.0 mask 255.255.255.252
Ø
neighbor 192.192.1.6 remote-as 65001
Ø
neighbor 192.192.1.6 description
R1
Ø
neighbor 200.200.1.2 remote-as 65003
Ø
neighbor 200.200.1.2 description
VODAFONE_ISP
Ø
no auto-summary
v
Vodafone_ISP {BGP} Configuration:-
Ø
Vodafone_ISP
(config)#router bgp 65003
Ø
no
synchronization
Ø
bgp router-id 5.5.5.5
Ø
network 200.200.1.0 mask 255.255.255.252
Ø
network 200.200.1.4 mask 255.255.255.252
Ø
neighbor 200.200.1.1 remote-as 65004
Ø
neighbor 200.200.1.1 description
RELIANCE_ISP
Ø
neighbor 200.200.1.5 remote-as 65002
Ø
neighbor 200.200.1.5 description
AIRTEL_ISP
Ø
no auto-summary
Troubleshooting & Verification Commands:-
Ø
show
ip route
Ø
show
ip interface brief
Ø
show
ip bgp summary {Shows BGP neighbor}
Ø
show
ip bgp {Shows BGP network information}
Ø
show
ip bgp neighbor
0 comments:
Post a Comment